In module 8 Session id is not generating | SOAPUI Forum

In module 8 Session id is not generating

Y
Yanamala Kiran Post on 29/12/2019

Request: 

<soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:RetailApp">
<soapenv:Header/>
<soapenv:Body>
<urn:RetailLogin soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<credentials xsi:type="nam:credentials" xmlns:nam="http://localhost/retail/namespaces">
<!--You may enter the following 2 items in any order-->
<username xsi:type="xsd:string">user</username>
<password xsi:type="xsd:string">whizdom</password>
</credentials>
</urn:RetailLogin>
</soapenv:Body>
</soapenv:Envelope>

 

Response:

<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:tns="http://localhost/retail/namespaces">
<SOAP-ENV:Body>
<ns1:RetailLoginResponse xmlns:ns1="urn:RetailApp">
<return xsi:type="tns:loginresponse">
<loginusername xsi:type="xsd:string">user</loginusername>
<sessionid xsi:type="xsd:string"><![CDATA[<html>
<head><title>301 Moved Permanently</title></head>
<body>
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>]]></sessionid>
<role xsi:type="xsd:string">customer</role>
<loginstatus xsi:type="xsd:string">loggedin</loginstatus>
</return>
</ns1:RetailLoginResponse>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>